svnant不支持svn版本1.7

看了标题进来的吧,话说事情是这个样子的。以前SVN服务版本是1.6,svnant版本是1.3.1,官网明确说明只支持到1.6.x。由于升级了SVN版本到1.7,然后问题就来了。

svnant官网:http://subclipse.tigris.org/svnant.html
123.png

源自国外网站的问题:
http://stackoverflow.com/questions/11557637/svnant-does-not-support-svn-version-1-7-what-to-do/11558376#11558376

我使用tortoise svn,最近我更新到1.7版本。仍然,在我们的构建系统(ant脚本)中,我们使用svnant lib(获取当前版本号,我们使用它作为版本号)。所以不能再构建项目,因为svnant不支持1.7版本的svn。我如何解决这个问题?

先谢谢你!

答案大致说了三种实现方式:
svnkit版本地址:https://svnkit.com/download.php

谷歌开源版本:https://github.com/opticyclic/svntask

以上2种方式本人都没有测试成功。

测试成功的方法如下:

svnant现已在源中更新以支持SVN 1.7,但您需要自己构建它。
在命令提示符下:
检查svnant到本地目录(用户名guest,空密码):
svn co http://subclipse.tigris.org/svn/subclipse/trunk/svnant/ svnant --username=guest

CD进入根svnant目录执行一下命令
ant makeDistrib

生成的JAR包一般会在这个目录 C:UsersAdministratorsvnantbuilddistriblib

然后把JAR包放到apache-ant目录的lib下面、xml脚本引入即可。
内联属性,如svnkit =“false” javahl="false" 已经废弃,所以你将需要更新的描述使用svnSetting

qrcode_for_gh_bf7a27ade681_258.jpg

作者: 小柒

出处: https://blog.52itstyle.com

分享是快乐的,也见证了个人成长历程,文章大多都是工作经验总结以及平时学习积累,基于自身认知不足之处在所难免,也请大家指正,共同进步。

本文版权归作者所有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出, 如有问题, 可邮件(345849402@qq.com)咨询。