linux下 Error running javac compiler

由于Linux版本更新,虽然软件都拷贝过来了,但是系统环境重新配置。

旧系统配置了ANT一键部署功能的脚本,由于部署需要,所以这里又重新配置了下环境。

1、ANT版本 1.9.2 软件路径 /usr/local/apache-ant-1.9.2/

vi etc/profile (追加一下代码即可)

#set Ant enviroment
export ANT_HOME=/usr/local/apache-ant-1.9.2
export PATH=$PATH:$ANT_HOME/bin

2、执行命令 ant -version 检查是否配置ok。
提示一下错误信息

Unable to locate tools.jar. Expected to find it in /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.131-2.6.9.0.el7_3.x86_64/lib/tools.jar

检查下JDK环境是否安装成功。

3、java -version 发现是openJDK版本,开始以为是环境变量的问题,因为openJDK安装的时候是默认的。

vi etc/profile (追加JDK环境变量)

#set JDK  enviroment

export JAVA_HOME=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.131-2.6.9.0.el7_3.x86_64  

export CLASSPATH=.:$JAVA_HOME/jre/lib/rt.jar:$JAVA_HOME/lib/dt.jar:$JAVA_HOME/lib/tools.jar 

export PATH=$PATH:$JAVA_HOME/bin  

然而你有没有发现JAVA_HOME 下面根本没有所谓的lib文件,于是目录下自建lib目录,把本地的相关jar拷贝进去,然后 source /etc/proifle。

4、然后重新执行脚本,又报错了:

Error running javac compiler

翻译一下可能就是无法找到javac编译器。

百度搜了一下,终于在老外的网站找到了问题。由于openJDK默认值安装了jre,也就是java运行环境,并没有安装java开发环境,所以导致打包失败。

执行一下命令:

yum install java-1.7.0-openjdk-devel

这时候 /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.131-2.6.9.0.el7_3.x86_64 目录下会多了好几个文件,就比如我们缺少的lib目录。

重新执行ANT脚本,部署成功。

qrcode_for_gh_bf7a27ade681_258.jpg

作者: 小柒

出处: https://blog.52itstyle.com

分享是快乐的,也见证了个人成长历程,文章大多都是工作经验总结以及平时学习积累,基于自身认知不足之处在所难免,也请大家指正,共同进步。

本文版权归作者所有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出, 如有问题, 可邮件(345849402@qq.com)咨询。